Network
Incident Report for Think Cloud
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 19:20 BST
Investigating
we have been experiencing high latency which the network have been looking into and resolved no further action is needed
Posted Sep 20, 2022 - 19:20 BST
This incident affected: Core Network.