Cloud Network Ouatage
Incident Report for Think Cloud
Resolved
The cloud storage issue has now been resolved, service will become operational shortly.
Posted Oct 18, 2023 - 15:54 BST
Update
We understand the inconvenience this may have caused and would like to provide you with a detailed update on the situation.

Initial Issue: The incident began with the identification of an issue within our cloud network, specifically involving one of the critical network switches. This switch played an essential role in maintaining the integrity and functionality of our cloud services.

Resolution of Switch Failure: Our technical team promptly addressed the switch failure, working diligently to restore normal operations. Once the switch issue was resolved, we observed that parts of the cloud network were gradually becoming operational.

Discovery of Cloud Data Store Issue: Subsequently, our engineers conducted a thorough investigation into the network outage to pinpoint the root cause of the disruption. After an assessment, we identified a separate issue within one of our cloud data stores.

Current Status: As of now, our engineers are actively working to resolve the issue with the affected cloud data store. We want to assure you that every effort is being made to rectify this situation as swiftly as possible to minimise any further disruptions and to ensure the robustness of our cloud services.

We understand the importance of our services to your business operations, and we sincerely apologise for any inconvenience this outage may have caused. Please be assured that we are committed to resolving this issue and taking steps to prevent similar incidents in the future.
Posted Oct 18, 2023 - 10:15 BST
Update
We are currently looking into problems within our cloud storage network.

The functionality of your server may vary depending on its location within the cloud.
Posted Oct 18, 2023 - 01:33 BST
Update
Although services associated with the cloud network momentarily became operational, we saw fluctuations across the network.

Engineers are currently replacing the switch responsible for these fluctuations, some clients will be affected.
Posted Oct 17, 2023 - 18:02 BST
Update
Engineers have located the fault, we are expecting the issue to be resolved within the hour.
Posted Oct 17, 2023 - 14:09 BST
Update
Engineers are on site investigating the issue.
Posted Oct 17, 2023 - 13:13 BST
Investigating
We are currently investigating an outage with our cloud network.

We will provide an update shortly.
Posted Oct 17, 2023 - 12:40 BST
This incident affected: Cloud Network.